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SpectraPlotterMap version 12, included in Radial Suite Release 8, 
displays  two  and  three  dimensional  plots  of  power  spectra 
generated  by  the  SeaSonde.  The  power  spectrum  is  a  visual 

representation  of  the  sea  echo  received  by  the  SeaSonde  which  is  used  to 
evaluate the quality and the nature of the signal.

SpectraPlotterMap  12  supports  Cross  Spectra  version  6  files,  which  contain 
more meta data than prior versions and embedded first order limit lines.

SpectraPlotterMap 12 generates spectral plots for the two loop antennas and 
the vertical  antenna (previously  referred to as  the monopole or  the dipole). 
Buttons on the main window allow easy access to the information, range slice, 
doppler slice, and first order windows.

SpectralPlotterMap  12  adds  keyboard-controlled  zoom  capabilities  with 
enhanced pixelation, font size control,  and Portable Document Format (PDF) 
export for clean graphics.

SpectraPlotterMap Features

Graphically enhanced power spectra plots 

Manipulate font size of graphic labels and export to PDF format for 
high quality report and scientific study figures 

Navigate data with multiple keyboard short cut options

Activate and deactivate spectra for one, two, or three antenna elements 
new toolbar buttons

SpectraPlotterMap 12 User Guide



Basics

Open a cross spectra (spectra) file by: 
Open SpectraPlotterMap and follow the prompt to drop a spectra file onto 
the window with tray icon

Drag and drop the spectra file on the SpectraPlotterMap icon
 

Drag and drop the spectra file into the SpectraPlotterMap window

Open SpectraPlotterMap, select main menu File->Open and locate 
spectra file

Once a SpectraPlotterMap session has been initiated, double click spectra 
file to launch it into SpectraPlotterMap

Spectra data will appear in the main window of SpectraPlotterMap. The example  
used  throughout  this  Guide  is  from the  BML1  site  located  in  Bodega  Bay, 
California, United States. 

Main SpectraPlotterMap Window

Spectra Color Map
The Spectra Color Map is the power received from the three antenna elements 
over range and Doppler. The vertical axis is range (radial distance) from the 
site. The horizontal axis is sea-echo Doppler represented here as radial current 
velocity. The left half is echo from Bragg waves moving towards the site while 
the right half is from Bragg waves moving away from the site. Both Bragg waves 
are shown here as current velocity moving towards (positive) and away from 
(negative)  the  site.  Each dot  in  the  plot  represents  a  single  range cell  and 
doppler bin whose power is plotted as color. The power in dBm is represented 
by color based on the scale on the right which is adjustable for best contrast of 
the spectra. 
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SpectraPlotterMap’s  enhanced  main  window  features  a  new  toolbar  that 
provides access to all spectra data. The three buttons in the upper left corner 
control the plots that appear in the Spectra Color Map. Spectra for loop 1 (A1), 
loop 2 (A2), and the vertical antenna (A3) can be viewed together as shown 
below or removed from view by toggling the toolbar buttons. The Information, 
Range Slice, Doppler slice, and First Order Settings windows can be opened 
with their respective buttons in the upper right corner.

Range can be expressed as distance or as range cells which are the discrete 
processing distances.  The range nearest  the  SeaSonde contain  the warmest 
intensity  colors  (yellow  and  green  in  this  example)  because  their  signal  is 
strongest.  The  signal  tends  to  decrease  with  increasing  distance  from  the 
SeaSonde, as reflected in the progressing cooling of intensity coloration from 
cyan to blue to dark purple. 

Clicking in the body of any of the three panels in the Spectra Color Map will 
add a cursor (small black rectangle indicated below by the large red arrow) to 
select a single range cell and Doppler bin. The Range Slice, Doppler Slice, and 
Information windows all  track this cursor;  the up and down arrow keys will 



move the cursor around the Spectra Color Map and within the Range Slice, 
Doppler Slice, and Information windows. Here, the cursor is located at radial 
current  velocity  +28.5 cm/s and range cell  three.  For  the  vertical  antenna, 
which  we  focus  on  for  this  example,  range  cell  three  has  a  power  of 
approximately -80 dBm, given its orange coloring.
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Range Slice

The Range Slice is a plot of power versus Doppler for a selected range cell.  
This plot is useful for looking at first and second order for a single range cell. 

The  vertical  grey  line  at  power  -84  dBm  and  frequency  +28.5  cm/s  is 
consistent with the coordinates of the cursor in the Spectra Color Map. 

The  Range  Slice  plot  for  range  cell  three  plots  data  along  this  horizontal 
conceptual red horizontal line:

-84

+28.5



Doppler Slice

The Doppler Slice is a plot of power versus range for a Doppler bin. This plot is 
useful for examining how first order Bragg echo decays in range and where 
bistatic echoes show up by looking at the DC (zero velocity) Doppler bin.

 
The vertical grey line at power -84 dBm and range cell three is consistent with 
the coordinates of the cursor in the Spectra Color Map.

The Doppler Slice plot for Doppler bin 352 (radial velocity +28.5 cm/s) plots 
data along this vertical conceptual red horizontal line, looking to its left. Note 
the peak of the Doppler Slice is on the far left side of the graph, which is where 
it falls on the conceptual red line in the Spectra Color Map:
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Information

Information window is a text box with meta data describing the spectra file and 
SeaSonde site parameters in the first section, the active range cell in the second 
section,  and  the  active  Doppler  bin  in  the  third  section.  The  Information 
window will appear when you click the “Info” button. 

The selected range cell is shown as range cell three, and the selected Doppler 
bin is bin 352 (same as above example). Left Bragg and Right Bragg have Bragg 
indices in terms of Doppler bin, where the Bragg index occurs at a current 
velocity of zero.



First Order Settings

Introduction

Radials,  waves,  and ellipticals  require  accurately  determining the first  order 
region in the sea echo for optimal processing. The First Order Settings dialog 
adjusts the parameters that define how the first order determination algorithm 
operates.  Changing  these  settings  requires  a  fair  amount  of  skill;  please, 
contact CODAR support to obtain the best settings. The help notes on the right 
hand  panel  of  the  dialog  provide  a  summary  of  each  parameter  and 
recommendations for  settings. Hover over a parameter with your mouse to see 
these help notes.

The first order lines delineate the boundary of the first order region, which is 
the portion of the spectrum used to generate radial velocities. The first order is 
also  used  to  normalize  the  second  order  for  waves  computations,  where 
overestimating the first  order  region is  preferable  to  underestimating it  for 
computational  stability.  Elements  of  first  order  line  settings  for  waves, 
therefore, might be looser than they are for radials.  Elements of first order 
settings for elliptical calculations might also differ from radial settings because 
of their geometric complexity. If you wish to adjust first order lines for waves 
or ellipticals, first define them for radials, because two of the seven parameters 
are shared.

Default first order line parameters are first established in the default settings of 
SeaSondeRadialSiteSetup  and are  documented  in  the  RadialConfigs  file.  The 
range  cells  selected  to  be  processed  (the  processing  range  cells)  are  also 
identified  in  SeaSondeRadialSiteSetup.  The  first  range  cell,  for  example,  is 
typically not processed, and the second range cell is seldom processed. 

The processed first order lines are white in the Color Spectra Map and blue in 
the Range Slice plot. These processed first order lines are the result of the first 
order determination made by radial processing. The processed first order lines 
will not plot if they are missing from the cross spectra.



Selecting “Show Determined First Order” will display results of an immediate 
rough approximation of first order line placement if the settings in the First 
Order Settings window are applied to the processing spectra. The determined 
first order lines are plotted in pink in the Color Spectra Map and Range Slice 



plot.

In  this  example,  “Radial  BML1”  appears  in  the  dropdown in  the  upper  left, 
indicating that the first order settings used to generate radials  (and not waves 
or  ellipticals)  are  active  in  the  dialog.  “Processing  Range”  appears  in  the 
dropdown in the upper right indicating that default settings were applied to all 
of the range cells that were selected to be processed. Here we show the First 
Order Settings window and the resulting approximation of first order lines for 
the vertical antenna.

If  the estimation of the first order needs adjustment, the parameters within 
First Order Settings can be modified.

All these parameters below can be adjusted to see what might happen to the 
first order and do not take effect until you click the Save button which will then 
update  the  RadialConfigs  folder  and  will  be  applied  to  any  future  radial, 
elliptical, and wave processing. Clicking Revert button will reload this dialog 
with the RadialConfigs settings. Quitting without doing Save button will leave 
the RadialConfigs untouched.



 



First Order Setting Parameters

These seven adjustable first order line parameters are labeled below. The first 
four parameters are required and create the determined first order lines. The 
remaining three, optional parameters are used to narrow them if necessary. 

Maximum  Velocity  establishes  a  threshold  beyond  which  velocities  are 
excluded from the first order. The maximum radial velocity expected to occur 
at a given site should be entered. If this setting is too high, then non-Bragg 
data may be incorporated into the first order yielding an overestimated radial 
velocity.  If  it  is  too  low,  then  first  order  data  may  be  omitted  and  radial 
velocities will be underestimated. Maximum Velocity effectively establishes  a 
maximum allowable  first  order  width  which  is  equal  to  +/-  the  maximum 
velocity. 

The Doppler Smoothing factor is applied to remove irregular, jagged edges 
from the sea echo which might obscure the true boundary of the first order. 
The degree of smoothing is proportional to the number of points indicated by 
Doppler  Smoothing.  Smoothing  aids  in  a  later  step,  where  the  algorithm 
estimates the location of the low point (null) between the first order and either 
the second order or the noise floor. The image below on the left shows an 
example of the actual nulls represented by black dots for the spectra plotted in 
blue (A3). If the spectra are not smoothed sufficiently (Doppler Smoothing set 
too low), many jagged edges will remain. The algorithm will choose a null that 
is actually inside the first order, and the first order will be more narrow than it 
should be. This is represented in the middle image below. If the spectra have 
been over-smoothed (Doppler Smoothing set too high), too many points will be 
removed, the actual null between the first and second orders will disappear, 

Maximum Velocity ➤

Doppler Smoothing ➤ 

Signal to Noise ➤ 

Peak Power Dropoff ➤

Null Below Peak Power ➤

Reject Distant Bragg ➤

Reject Noise/Ionospheric ➤



and portions of the second order will be incorporated. The first order will be 
wider than it should be. An example of this shown in the image to the right.

After  the Doppler  are smoothed,  the algorithm moves down from the peak 
power and within the width generated by the maximum velocity to locate the 
first order limits within the smoothed Doppler.  To confine this search, First 
Order Settings provide two thresholds. Signal to Noise limits the lower end of 
the search with the noise floor. If the algorithm hits the noise floor, defined in 
dB, then it will stop its search and set limits. The descent from peak power is 
also  confined  by  Peak  Power  Dropoff,  expressed  in  dB.  If  the  algorithm 
reaches this distance, then first order limits are set. If this threshold is set too 
large, the algorithm may ascend too far down and incorporate data that is 
non-Bragg. If set too low, the algorithm may stop while still  inside the first 
order and omit portions of it. 

The more conservative of Signal to Noise and Peak Power Dropoff will prevail; if 
the Peak Power Dropoff limit is reached before the noise floor, then limits are 
set at that point. If the noise floor is reached before the Peak Power Dropoff 
value, then limits are set at the noise floor. 

At this point, the first order lines have been set and the remaining optional 
First  Order  Settings may be initiated to tighten the first  order  lines if  they 
appear too broad.  

Null Below Peak Power addresses conditions in which the second order signal 
is very close to the first order signal. This can occur in the presence of high, 
short waves that are just slightly longer in period and wavelength than Bragg 
waves. If the Null Below Peak Power box is checked, first order limits will stop 
at  the first  null  that  is  beyond the minimum specified quantity  below peak 
power in dB. Null Below Peak Power will have no effect if set higher than the 
Peak Power Dropoff, which would trip before the Null Below Peak Power value is 
met. This parameter was left unchecked for the positive Bragg shown on the 
left, while Null Below Peak Power was checked and given a value of 6 dB for the 

Nulls Nulls with too much Nulls with not enough 
smoothing



example on the right,  which shows a slightly narrower first order region at 
about mid-range. 

Checking the Reject Distant Bragg box will prevent the misallocation of short 
bursts  of  energy,  such as  those associated with ships,  as  first  order  Bragg 
signal.  A  distance  check  prevents  this  error,  as  illustrated  in  the  example 
below.  Here,  the  determined  first  order  lines  deviate  to  the  left  from  an 
otherwise reasonable delineation to include a high intensity region. The Bragg 
index, located at current velocity zero, is marked below along with the left and 
right first order lines for this range cell. The width of the erroneous first order 
region is called out. 

If  this width is 
smaller t h a n 
t h e 

distance 
between either first order line and the Bragg index, than the selection will be 
rejected because it is too far away to reasonably constitute the first order.



Clearly, the selected first order width is smaller than distance d1 (right first 
order line and the Bragg index) and distance d2 (left first order line and the 
Bragg index), so the selected first order for this range cell is rejected which 
means that the positive(right) Bragg for this range cell will not be processed 
into future radials. If the negative(left) Bragg is also rejected, then there won't 
be any radial vectors for the range cell, which is good because they're likely 
invalid. When tripped, all the doppler bins for Bragg half will be plotted much 
darker  as  an  indicator  unless  the  menu item Power -> Grey Doppler  for 
Rejected Bragg is unchecked.

Reject  Noise/Ionospheric  rejects  Bragg  when  the  total  non-Bragg  power 
within a given range cell is greater than the power within the first order. This 
prevents  inclusion  of  contaminated  data  at  times  and  locations  where 
significant  noise  is  expected.  Just  like  Reject  Distance  Bragg  above,  when 
tripped, there won’t be any future radials for that range cell and Bragg half and 
all the doppler bins for Bragg half will be plotted much darker unless the menu 
item Power -> Grey Doppler for Rejected Bragg is unchecked.

When checked, Blackout shows an estimate of the regions in the spectral plot 
that would be rejected if the settings in the First Order Settings window were 
implemented. The drop down menu allows selection of all or specific tests. This 
is  very  useful  in  understanding  how First  Order  Settings  might  impact  the 
region in the Spectra Color Map identified as first order. The menu item Power 
-> Adjust Blackout Opaque provides a scale for adjusting the opaqueness of 
the blackout, where 100% is fully black and 0% is barely visible. This example 
shows the effects of a 70% setting.



Blackout can also show where SpectraAverager had decided to leave out data 
from the averaged spectra due to ships and interference by flagging the vertical 
antenna (A3) with a negative value.
 

Tailoring First Order Settings to Seasonal and Spatial Variation

When adjusting the First Order Settings, do not try to perfect them for a single  
file, rather, establish reasonable first order lines for a given set of files. Scroll 
forward  (backward)  through  a  folder  of  files  using  the  <command> 
‘ (<command> ;) keyboard shortcut and observe the processed and determined 
first order lines. Try to make adjustments that are loose enough as to benefit, 
or at least not hinder, the other spectra files.

Because environmental conditions change over time, checking back periodically 
to  evaluate  the  performance  of  your  settings  is  recommended.  If  seasonal 
conditions create predictable changes in the first order region, you can develop 
First Order Settings for two or more different seasons and manually enter them 
at the appropriate time. 

If  your site contains a region with distinct features that influence the Bragg 
region like an enclosed bay or channel, establishing first order settings for one 
or more groups of range cells allows you optimize your site. For example, a 
shallow, nearshore area in an otherwise deep region may benefit from having 
unique  first  order  settings.  An  area  with  significant  river  inflow  may  also 
warrant its own first order settings.   SpectraPlotter Map allows the creation of 
different settings for distinct groups of range cells. 



Click the “+” button next to “Processing Range” to add a sub-group of range 
cells. Select a sub-group in the dropdown and edit the range cell numbers in 
the  box  below.  If  you  require  range  cells  that  lie  outside  of  the  group  of 
processing range cells,  click the “Go to Site Setup” button.  This will  launch 
SeaSondeRadialSetup and allow you to adjust the radial processing range. In 
the First Order Settings window, select the sub-group of range cells you wish 
to  edit,  enter  the  desired  settings,  and  save  these  settings.  While  you  can 
create  up to  32 sub-groups,  adding just  one sub-group,  if  at  all,  is  more 
typical.

To adjust first order line settings for waves, use the dropdown menu under 
“Show Determined First Order” to select the wave option. The parameters that 
apply  to  wave  processing  will  be  editable,  those  that  do  not  apply  will  be 
greyed  out.  To  adjust  first  order  line  settings  for  ellipticals,  use  the  same 
dropdown to select the elliptical option and modify the editable parameters.   
Settings  for  waves  and  ellipticals  requires  advanced  skill;  please,  contact 
CODAR support to obtain the best settings for your site(s). 

Saving First Order Settings

After you have made the desired adjustments, click the “Save” button to save 
them. If you wish to undo them and see the original settings, click the “Revert” 
button.  Saving  the  settings  will  effect  all  future  radial,  elliptical  and  wave 
processing.



SpectraPlotterMap Menu

Find version information about SpectraPlotterMap under SpectraPlotterMap-
>About  SpectraPlotterMap.  Hide  SpectraPlotterMap  will  remove 
SpectraPlotterMap from view, Hide Others hides all  other open applications, 
and Show All brings them back into view. Quit SpectraPlotterMap closes the 
application. 

Main Menu

The application has eight pulldown menus: File, Edit, Doppler, Power, Graph, 
Zoom, View, and Window. Keyboard shortcuts are shown to the right of each 
item, for example, <command> O is the shortcut to open a file. 

File Menu

Files and file navigation are managed under the File menu. Spectra files can be 
opened from the main menu under File->Open. Next Spectra File (Previous 
Spectra File) and its keyboard shortcut <command> ‘ and <command> ; 
uploads the next  and previous spectra file in the folder where the currently 
active spectra resides. 



File->Close closes the active window. File->Save Image saves the main
window image as a PDF or PNG file. The infinite resolution PDF format provides 
figures for  scientific  studies  and reports  of  publishable  quality.  File->Page 
Setup provides a dialog with printer settings. File->Print opens a Print dialog 
with multiple options, including sending the main window image to a printer, a 
PDF file, or to the body of an email. 

File->First Order Settings opens up the dialog with parameters that define 
how the first order line algorithm operates. See First Order Settings section 
above for details. 

File->Movie  Maker  opens  a  dialog  for 
making movies comprised of a series of 
sequential  frames  from  Spectra  Color 
Map, Doppler Slice, or Range Slice. Movie 
Maker consists of these parameters: 

Destination  -  Click  the  “…”  button  to 
navigate to the folder where your movie 
will  be saved,  or  type it  in the adjacent 
window.  

Time Frame - indicate the time frame to 
be  included.  Select  “Entire  Folder”  to 
include content from all  spectral  files in 
the folder that contains your active file. 

Resolution  -  select  a  low  or  high 
resolution option. 

Codec  -  specify  the  desired  file  format 
and frames per second (FPS). 

Graph - select the content of your movie. 

Click  “Make Movie”  to  generate  a  *.mov 
file, and click “Close” to close out. 

Doppler Menu

The Doppler menu and keyboard shortcuts manipulate the Doppler and Range 
Slice.



�   
Doppler  -> Movie  Power  Up makes  an  upward  shift  in  the  values  of  the 
vertical axes in the Doppler and Range Slice. This shifts the vertical placement 
of data down.

Doppler -> Movie Power Down makes an downward shift in the values of the 
vertical axes in the Doppler and Range Slice. This shifts the vertical placement 
of data up.

Doppler  -> Spread Antennas  40dB spreads  power  data  for  each  antenna 
element in the Doppler and Range Slice by 40 dB for legibility. Instead of adding 
a unique vertical axis for each antenna, it provides a formula with the relative 
position of each dataset. For the actual power of A2, for example, add 20 dB to 
the plotted power since 20 dB were subtracted to shift it downward. An original 

Range Slice is shown on the left, and an adjusted plot is on the right:

Doppler -> Smooth Doppler toggles Doppler smoothing in the Range Slice as 
set by next menu item.

Doppler -> Smooth Doppler by… opens a smoothing factor dialog which sets 



the degree of smoothing applied to the Range Slice as shown below. 

Plot A3 Flagged toggles display of pink data line across the last horizontal 
graticule (-200 in above plot) that jumps up a couple of dB where the doppler 
cell  was  flagged  by  SpectraAverager  as  having  some of  the  source  spectra 
omitted from the average due to ship or interference. 

Plot Freshness toggles  display of a blue data line across the last horizontal 
graticule  (-200  in  above  plot)  that  drops  to  the  graph  edge  (-210)  as  an 
indication  by  SpectraAverager  that  data  does  not  contain  any  newer  (fresh) 
spectra in the average.

Plot Suppression toggles  display of orange data line across the last horizontal 
graticule  (-200  in  above  plot)  that  drop  to  the  graph  edge  (-210)  as  an 
indication by SeaSondeAcquisition where stripe suppression was applied.



Power Menu

The Power menu and keyboard shortcuts manipulate the Spectra Color Map. If 
the default settings do not reveal enough detail about an area of interest, like 
the peak power region of the first order, the Power menu provides the means to 
modify  how  the  data  are  plotted.  Some  of  its  features  also  impact  the 
appearance of the Doppler and Range Slice.

Power -> Move Signal Levels Up makes an upward shift in all values of the 
Spectra Color Map color bar, which shifts the colors plotted in the map down 
towards cooler tones. It also makes an upward shift in the values of the vertical 
axes in the Doppler and Range Slice. This shifts the vertical placement of data 
down.

Power -> Move Signal Levels Down makes a downward shift in all values of 
the Spectra Color Map color bar, which shifts the colors plotted in the map up 
towards warmer tones. It also makes an downward shift in the values of the 
vertical axes in the Doppler and Range Slice. This shifts the vertical placement 
of data up.

Power -> Move Maximum Up raises the highest value of the Spectra Color 
Map  color  bar  and  the  Spectra  Color  Map.  It  has  the  same  impact  on  the 
Doppler and Range Slice as Move Signal Levels Up. 



Power -> Move Maximum Down lowers the highest value of the Spectra Color 
Map  color  bar  and  the  Spectra  Color  Map.  It  has  the  same  impact  on  the 
Doppler and Range Slice as Move Signal Levels Down.

Power -> Move Threshold Up increases the mid-range value of color bar and 
opens up the spectrum of values plotted beneath it. It has no impact on the 
Doppler and Range Slice.

Power -> Move Threshold Down decreases the mid-range value of color bar 
and opens up the spectrum of values plotted above it. It has no impact on the 
Doppler and Range Slice.

Power -> Move Noise Floor Up raises the noise floor of the Spectra Color 
Map; increases the lowest intensity value plotted so that more of the map’s 
noise region is effectively blacked out.

Power -> Move Noise Floor Down lowers the noise floor of the Spectra Color 
Map; decreases the lowest intensity value plotted so that gradation is enhanced 
in the map’s noise region.

Power -> Move Selected Cell Left moves the cursor to the left (see below for 
toggling the cursor on).

Power -> Move Selected Cell Right moves the cursor to the right (see below 
for toggling the cursor on).

Power -> Move Selected Cell Up moves the cursor to the up (see below for 
toggling the cursor on).

Power -> Move Selected Cell Down moves the cursor to the down (see below 
for toggling the cursor on).

Power -> Set Default  Signal Levels undoes above commands that  change 
intensity  levels  in  the  color  bar  and Spectra  Color  Map plot  and reverts  to 
original settings.

Power -> Outline Selected Grey Cell toggles the cursor on if a cell is selected 
in the Spectra Color Map. 
Power -> Gray Doppler for Rejected Bragg shows the results of the Reject 
Distant Bragg and the Reject Noise/Ionospheric tests by coloring the rejected 
range  cells  dark  gray  in  the  Spectra  Color  Map.  These  two  tests  must  be 
checked in the First Order Settings window for this feature to display.

Power -> Gray First Order for Rejected Bragg shows the results of the Reject 



Distant Bragg and the Reject Noise/Ionospheric tests by coloring the first order 
lines in a paler pink than the accepted first order region in the Spectra Color 
Map. These two tests must be checked in the First Order Settings window for 
this feature to display.

Power -> Bound First Order replaces the continuous first order line with its 
vertical elements only.

Power -> Adjust Black Out Opaque… adjusts the opaqueness of the black out 
portion of the Spectra Color Map when Blackout is  checked. Selecting 100% 
hides the underlying data, whereas lowering it allows it to bleed through. 

Power -> Loop 1 toggles the appearance of the loop 1 plot in the Spectra 
Color Map.  

Power -> Loop 2 toggles the appearance of the loop 2 plot in the Spectra 
Color Map.  
 
Power -> Vertical toggles the appearance of the vertical antenna plot in the 
Spectra Color Map.  



Graph Menu

The Graph menu controls font size of axes and the variables that are plotted.
Graph -> Font Bigger increases the font size of all three plots. 

Graph -> Font Smaller decreases the font size of all three plots.

Graph -> Set Default Font Size applies the default font size of all three plots.

Graph -> Toggle Range Units cycles through available options for range units 
(displayed on the horizontal axis of the Doppler Slice and on the vertical axis of 
the Spectra Color Map).

Graph -> Range Cells sets the units of range in terms of range cell. 

Graph -> Range Kilometers sets the units of range in terms of kilometers.

Graph -> Range Miles sets the units of range in terms of miles.

Graph -> Range Nautical Miles sets the units of range in terms of nautical 
miles.

Graph -> Toggle Doppler Units cycles through available options for Doppler. 
units (displayed on the horizontal axis of the Range Slice and on the horizontal 
axis of the Spectra Color Map).



Graph -> Doppler Bins from DC sets the units of Doppler in terms of Doppler 
bins from DC (zero Doppler).

Graph -> Doppler Bins Index sets the units of Doppler in terms of Doppler 
bin index.

Graph -> Doppler Radial Velocity cm/s sets the units of Doppler in terms of 
radial current velocity in centimeters per second.

Graph -> Doppler Target Velocity m/s sets the units of Doppler in terms of 
Doppler velocity in meters per second.

Graph -> Doppler Target Velocity mph sets the units of Doppler in terms of 
Doppler velocity in miles per hour.

Graph -> Doppler Hz sets the units of Doppler in terms hertz.

Zoom Menu 

The zoom window controls the size of the Spectra Color Map window. The Info, 
Doppler Slice, and Range Slice windows can be adjusted by right selecting a 
corner and dragging the mouse. The Spectra Color Map window, however, is 
comprised of pixels that can’t be adjusted as freely. 

Zoom -> Zoom In Range/Doppler increases both dimensions of the Spectra 
Color Map window. 

Zoom -> Zoom Out Range/Doppler decreases both dimensions of the Spectra 
Color Map window.

Zoom -> Zoom In Range increases the vertical dimension of the Spectra Color 
Map window.



Zoom -> Zoom Out Range  increases the vertical  dimension of the Spectra 
Color Map window.

Zoom -> Zoom In Doppler increases the horizontal dimension of the Spectra 
Color Map window.

Zoom -> Zoom Out Doppler increases the horizontal dimension of the Spectra 
Color Map window.

Zoom -> Zoom To  Default  returns  the  Spectra  Color  Map  window  to  its 
original state.

View Menu

View -> Hide Toolbar toggles the appearance of the toolbar in Spectra Color 
Map. 



Window Menu

The Window menu controls which windows are active and how they appear. 
Pressing the option key before the Minimize or Zoom commands applies them 
to all open windows. Bring All to Front and Arrange in Front provides a quick 
way to locate your open SpectraPlotterMap windows. 

�

The Spectra Information, Spectra Color Map, Range Slice, and Doppler Slice can 
be  activated  and  deactivated  with  this  menu.  See  above  sections  on  these 
windows for details about their content. The active spectra file is shown at the 
bottom of this menu.  
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